The Iconfactory

Support

Software Support Item

What are the system requirements to run xScope?

xScope requires a Mac running a minimum system of 10.7 (Lion).

Search for similar items

Can't Find It?

We've tried to anticipate most questions you might have. However, if you can't find the answer you're looking for here, send us your query and we'll answer it personally.

Send to: